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OVERVIEW 

The Saleng Tiny13 is an 8-bit, Arduino compatible 
microcontroller board complete with on board regulator, 
user friendly 2.54mm headers and built-in LED. It is 
probably the simplest Arduino compatible board with 
only 1Kb of flash, 64 bytes RAM, 64 bytes EEPROM, and 5 
useable GPIO’s. Of the 5 I/O pins available, 3 can be used 
as analog input pins (ADC), 2 are PWM capable and one 
pin is an external interrupt pin. The microcontroller has 
an SPI peripheral accessible from the same GPIO pins. The 
clock source is selected from any of the internal clock 
sources: 1.2MHz, 4.8MHz, and 9.6MHz. There are more 
than one Arduino-core board files that can be used with 
this board to be able to use it with the Arduino IDE if 
desired. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
These specifications are more than enough to implement 
projects that are otherwise overkill/expensive for a 
standard Arduino board. This board has the same ATtiny 
processor as its larger variants such as the Attiny85.  The 
processor has throughputs approaching 1 MIPS per MHz. 
 
The simplicity of this board pushes its price down to 
probably the lowest level yet. With this simpler 
specifications however, the board requires an ISP 
programmer , such as the Kimat Arduino ISP  Shield, 
Atmel ICE, USPASP, AVRISP, STK500 or the DIY 

programmer ArduinoISP, tobe able to upload code and 
set its fuses for clock and other optional settings. The 
board does not have a hardware UART (“Serial”) but 
some Arduino cores may support simplified 
softwareSerial – styled software UART. While a 
bootloader may be used, it may be impractical as the 
code size alone has a significant footprint. Hence, we 
recommend to use this board without bootloader and 
upload code via ISP port. 
 
FEATURES 

• High performance AVR® 8-Bit Microcontroller  

• Operating Voltage: 5V 

• Low Power Consumption  

• Internal 5V, 1A regulator 

• Wide Vin - 6-12Vdc 

• Builtin LED 

• Small Compact Size 

• Inexpensive 

• Arduino Compatible 

 

PIN FUNCTIONS 

Saleng Tiny13 
Pins 

Function 

VIN Input Power Pin, 6-12V 

VCC 5V output 

GND Ground 

RST   Reset pin. 

D0 / MOSI  Digital pin 0 / MOSI, connected 
internally to builtin LED “L” 

D1 / MISO Digital pin 1 / MOSI 

A1 / D2/ SCK /  Analog pin 1 or Digital pin 2/SCK 

A2 / D3  Analog pin 2 or Digital pin 3 

A3 / D4 Digital & Analog input / output 

 

 

 

 

 

 

 

 

Figure 1:  Saleng Tiny13 
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PINOUT DIAGRAM 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

INSTALLING THE BOARD ON THE ARDUINO IDE 

 

As there are more than one compatible Arduino-core , 

this document  will focus on the the MicroCore. When 

the core is installed in the Arduino IDE, a new board 

under the Tools>Board menu shall appear and may be 

used with the Saleng Tiny13. MicroCore requires 

Arduino IDE version 1.6.13 or greater. To install via 

Board Manager, follow these steps. Other installation 

methods are discussed on the MicroCore repository. 

This installation is required before the Saleng Tiny13 can 

be used with the Arduino IDE. 

Follow these steps: 

• Open the Arduino IDE. 

• Open the File > Preferences menu item. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3: Preferences of Arduino IDE 

 

 

Figure 2: Saleng Tiny13 Pin outs 

 

https://github.com/MCUdude/MicroCore
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• Enter the following URL in Additional Boards 

Manager URLs: 

https://mcudude.github.io/MicroCore/package_

MCUdude_MicroCore_index.json 

 
• Open the Tools > Board > Boards Manager... 

menu item. 

 
• Wait for the platform indexes to finish 

downloading. 

• Scroll down until you see the MicroCore entry 

and click on it. 

• Click Install. 

 

 

 
• After installation is complete close the Boards 

Manager window. 

 

UPLOADING SKETCHES 

 

Unlike a regular Arduino board such as an Uno that is 

programmed with a bootloader and has a dedicated USB 

port, the Saleng Tiny13 is programmed via the ISP port. 

The procedure for ISP writing the program is the same 

for all boards with classic AVRs, including Arduino 

Uno/Nano/Mega. 

An ISP programmer is required for uploads. While this 

document will focus on the Kimat Arduino ISP Shield as 

an ISP programmer, others may be use such as the 

USBASP, Atmel ICE, AVRISP or STK500. 

After successful installation of MicroCore , connect the 

Kimat Arduino ISP shield (and host Uno board) to Saleng 

Tiny13. 

Kimat Arduino ISP shield Saleng Tiny13 

SCK A1 / SCK / D2 

MISO D1 / MISO 

MOSI D0 / MOSI 

RST RST / A0 

GND GND 

VCC VCC 

 

 

Figure 4: Paste Board Manager URL 

 

 

Figure 5: Board Manager 

 

 

Figure 6: Click install 

 

https://mcudude.github.io/MicroCore/package_MCUdude_MicroCore_index.json
https://mcudude.github.io/MicroCore/package_MCUdude_MicroCore_index.json
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• Select the ATtiny13 MicroCore board and set the 

settings as: 

 

• After setting up the board, upload a sketch by 

using Upload using programmer feature and 

done. 

 

 

 

 

APPLICATION NOTES 

 

First Test 

 

Before proceeding make sure that all of the steps above were successfully done. Always check your power supply 

connection a double 5v power supply connected to the VCC can damage the circuit. The Two Vcc and ground are intended 

for the components not to Saleng Tiny13. 

 

 

Figure 8: Board Setting of Saleng Tiny13 

 

 

 

Figure 9: Upload sketch on Saleng Tiny13 
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Upload a blinking LED sketch to determine if the Arduino Uno is able to upload code on Saleng Tiny13. 

 

CODE: 

 
 This example code is in the public domain. 
 
  http://www.arduino.cc/en/Tutorial/Blink 
*/ 
 
// the setup function runs once when you press reset or power the board 
void setup() { 
  // initialize digital pin LED_BUILTIN as an output. 
  pinMode(LED_BUILTIN, OUTPUT); 
} 
 
// the loop function runs over and over again forever 
void loop() { 
  digitalWrite(LED_BUILTIN, HIGH);   // turn the LED on (HIGH is the voltage level) 
  delay(1000);                       // wait for a second 
  digitalWrite(LED_BUILTIN, LOW);    // turn the LED off by making the voltage LOW 
  delay(1000);                       // wait for a second 
} 

 

The L LED should blink if the sketch was successfully uploaded. 
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WIRING DIAGRAM: 

 

DOCUMENT REVISION HISTORY 

Revision:  

v1.0.0/04 May 2020 R.J.Quirante/ C.D.Malecdan 

 

 

Figure 10: Wiring example for an Arduino Uno and Saleng Tiny13 connection. 
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IMPORTANT NOTICE 

Layad Circuits Electronics Engineering Supplies & Services (Layad Circuits) 

reserves the right to make corrections, enhancements, improvements and 

other changes to its products, services and documentations, and to 

discontinue any product or service. Buyers or clients should obtain the latest 

relevant information before placing orders and should verify that such 

information is current and complete. Additional terms may apply to the use 

or sale of Layad Circuits products and services.  

Reproduction of significant portions of Layad Circuits information in Layad 

Circuits datasheets or user guides is permissible only if reproduction is 

without alteration, displays the Layad Circuits logo and is accompanied by all 

associated warranties, conditions, limitations, and notices. Layad Circuits is 

not responsible or liable for such reproduced documentation. Information of 

third parties may be subject to additional restrictions. Resale of Layad 

Circuits products or services with statements different from or beyond the 

parameters stated by Layad Circuits for that product or service voids all 

express and any implied warranties for the associated Layad Circuits product 

or service. Layad Circuits is not responsible or liable for any such statements.  

Buyers and others who are developing systems that incorporate Layad 

Circuits products (collectively, “Designers”) understand and agree that 

Designers remain responsible for using their independent analysis, evaluation 

and judgment in designing their applications and that Designers have full and 

exclusive responsibility to assure the safety of Designers' applications and 

compliance of their applications (and of all Layad Circuits products used in or 

for Designers’ applications) with all applicable regulations, laws and other 

applicable requirements. Designer represents that, with respect to their 

applications, Designer has all the necessary expertise to create and 

implement safeguards that (1) anticipate dangerous consequences of 

failures, (2) monitor failures and their consequences, and (3) lessen the 

likelihood of failures that might cause harm and take appropriate actions. 

Designer agrees that prior to using or distributing any applications that 

include Layad Circuits products, Designer will thoroughly test such 

applications and the functionality of such Layad Circuits products as used in 

such applications. Layad Circuits’ provision of technical, application or other 

design advice, quality characterization, reliability data or other services or 

information, including, but not limited to, reference designs and materials 

relating to evaluation modules, (collectively, “Layad Circuits Resources”) are 

intended to assist designers who are developing applications that 

incorporate Layad Circuits products; by downloading, accessing or using 

Layad Circuits Resources in any way, Designer (individually or, if Designer is 

acting on behalf of a company, Designer’s company) agrees to use any 

particular Layad Circuits Resource solely for this purpose and subject to the 

terms of this Notice.  

Layad Circuits' provision of Layad Circuits Resources does not expand or 

otherwise alter Layad Circuits’ applicable published warranties or warranty 

disclaimers for Layad Circuits products, and no additional obligations or 

liabilities arise from Layad Circuits providing such Layad Circuits Resources.  

Layad Circuits reserves the right to make corrections, enhancements, 

improvements and other changes to its Layad Circuits Resources. Layad 

Circuits has not conducted any testing other than that specifically described 

in the published documentation for a particular Layad Circuits Resource.  

NO OTHER LICENSE, EXPRESS OR IMPLIED, BY ESTOPPEL OR OTHERWISE TO 

ANY OTHER LAYAD CIRCUITS INTELLECTUAL PROPERTY RIGHT, AND NO 

LICENSE TO ANY TECHNOLOGY OR INTELLECTUAL PROPERTY RIGHT OF LAYAD 

CIRCUITS OR ANY THIRD PARTY IS GRANTED HEREIN, including but not limited 

to any patent right, copyright, mask work right, or other intellectual property 

right relating to any combination, machine, or process in which Layad Circuits 

products or services are used. Information regarding or referencing third-

party products or services does not constitute a license to use such products 

or services, or a warranty or endorsement thereof. Use of Layad Circuits 

Resources may require a license from a third party under the patents or 

other intellectual property of the third party, or a license from Layad Circuits 

under the patents or other intellectual property of Layad Circuits. Layad 

Circuits RESOURCES ARE PROVIDED “AS IS” AND WITH ALL FAULTS. LAYAD 

CIRCUITS DISCLAIMS ALL OTHER WARRANTIES OR REPRESENTATIONS, 

EXPRESS OR IMPLIED, REGARDING RESOURCES OR USE THEREOF, INCLUDING 

BUT NOT LIMITED TO ACCURACY OR COMPLETENESS, TITLE, ANY EPIDEMIC 

FAILURE WARRANTY AND ANY IMPLIED WARRANTIES OF MERCHANTABILITY, 

FITNESS FOR A PARTICULAR PURPOSE, AND NON-INFRINGEMENT OF ANY 

THIRD PARTY INTELLECTUAL PROPERTY RIGHTS. LAYAD CIRCUITS SHALL NOT 

BE LIABLE FOR AND SHALL NOT DEFEND OR INDEMNIFY DESIGNER AGAINST 

ANY CLAIM, INCLUDING BUT NOT LIMITED TO ANY INFRINGEMENT CLAIM 

THAT RELATES TO OR IS BASED ON ANY COMBINATION OF PRODUCTS EVEN 

IF DESCRIBED IN LAYAD CIRCUITS RESOURCES OR OTHERWISE. IN NO EVENT 

SHALL LAYAD CIRCUITS BE LIABLE FOR ANY ACTUAL, DIRECT, SPECIAL, 

COLLATERAL, INDIRECT, PUNITIVE, INCIDENTAL, CONSEQUENTIAL OR 

EXEMPLARY DAMAGES IN CONNECTION WITH OR ARISING OUT OF LAYAD 

CIRCUITS RESOURCES OR USE THEREOF, AND REGARDLESS OF WHETHER 

LAYAD CIRCUITS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. 

Unless Layad Circuits has explicitly designated an individual product as 

meeting the requirements of a particular industry standard, Layad Circuits is 

not responsible for any failure to meet such industry standard requirements. 

Where Layad Circuits specifically promotes products as facilitating functional 

safety or as compliant with industry functional safety standards, such 

products are intended to help enable customers to design and create their 

own applications that meet applicable functional safety standards and 

requirements. Using products in an application does not by itself establish 

any safety features in the application. Designers must ensure compliance 

with safety-related requirements and standards applicable to their 

applications. Designer may NOT use any Layad Circuits products in life-critical 

applications. Life-critical medical equipment is medical equipment where 

failure of such equipment would cause serious bodily injury or death (e.g., 

life support, pacemakers, defibrillators, heart pumps, neurostimulators, and 

implantables). Designers agree that it has the necessary expertise to select 

the product with the appropriate qualification designation for their 

applications and that proper product selection is at Designers’ own risk. 

Designers are solely responsible for compliance with all legal and regulatory 

requirements in connection with such selection. Designer will fully indemnify 

Layad Circuits and its representatives against any damages, costs, losses, 

and/or liabilities arising out of Designer’s noncompliance with the terms and 

provisions of this Notice. 
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