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OVERVIEW 
 
The Saleng 128DB is an Arduino compatible board based on the new 
generation AVR128DB microcontroller under the modern AVR® 
family. The CPU runs at a maximum of 24MHz. It has a flash memory 
size of 128KB, 16KB SRAM, 512B EEPROM and 32B User row. The 
microcontroller features four 16-bit timers plus a 12-bit timer, 3 
hardware serial ports (UART), 12-bit ADCs or Analog pins, a DAC 
capable pin, internal zero cross detectors and op-amps, configurable 
custom logic and several other improvements from the “classic” 
chips such as those used in the Arduino Uno/Nano and Mega. 
 
The Board comes with a total of 21 GPIO’s on board with standard 
2.54mm-pitched pin headers. 9 of the 21 pins may be used as analog 
input pins (ADC) with one DAC pin. 9 may be used for simultaneous 
PWM and all but two GPIOs are external interrupt capable.  
 
Programming may be done via the onboard micro-USB pin. Advance 
users may also access the exposed UPDI programming pin at the pin 
headers. The board comes with the usual reset button and the 
Arduino-Built-In-LED on pin D7. 
 
The Saleng 128DB has a selectable operating voltage of 5V or 3.3V 
via the on-board micro jumper. Another jumper is included to allow 
user selection of the Multi-Voltage I/O operating voltage (VDDIO2) 
between 5V or 3.3V which may act as built-in level-shifters. 
 

 
 
FEATURES 

• AVR128DB28 Microcontroller 

• Modern AVR architecture 

• CPU Clock Frequency of up to 24MHz 

• 16KB of SRAM Size 

• 128KB of Flash Size 

• 512 Bytes of EEPROM Memory 

• Total of 21 GPIO pins 

• 11 pins are capable of generating PWM signals  

• 9 Analog Pins with 12bit ADC 

• Mixed operating voltage of 3.3- and 5-volts via the MVIOs 

• Compatible with the Arduino IDE 

• Alternate UART and I2C Interface 

• Small form factor of 25mmx50mm PCB size 

• Power indicator LED, “L” LED 

• Affordable price 
 

TECHNICAL SPECIFICATIONS SUMMARY 
 

SALENG 128DB SPECIFICATION 

Clock Frequency 24MHz 

Flash Memory 128KB 

SRAM 16KB 

EEPROM 512B 

User Row Memory 32B 

Total GPIOs 21 

Max simultaneous PWM outputs 9 

External Interrupt Pins 19 

Language/IDE C/C++ / Arduino IDE 

DC Input Voltage Range via Vin 
header 

6.5 - 12V 
Recommended 

Direct Breadboard Compatibility 
(bottom male headers) 

Yes 

5V regulator current rating 1A 

3.3V regulator current rating 1A 

Selectable operating voltage 
Yes via microjumper, 

5V or 3.3V 

500mA PTC fuse on USB port Available 

Timers 4x 16-bit + 1x 12bit 

Hardware Serial (UART) 3 

Alternate UART Pins Available 

SPI port Available 

I2C port Available 

Alternate I2C pins Available 

10-bit DAC 1 

Analog Comparator 3 

Multi-Voltage IO pins (5V/3.3V) 4 

Zero-Cross Detectors 2 

On-chip Op amp 2 

Custom Logic Blocks 4 

Event System channels 8 channels 

Breadboard Compatible Yes 

Bootloaded Yes (Serial 0) 

On Board LEDs Power and “L” 

 
 
BASIC PIN FUNCTIONS 
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Note: A more elaborate pinout diagram can be seen on the section 

“DETAILED PINOUTS”  
 
PIN FUNCTION SUMMARY  
 
The table below describes the function of all of the pins on the main 
header. 
 

Board Label Pin Function 

VIN DC power input. 6-12V. Minimum 6.5V 
recommended. 

G Ground 

V VDD pin. This will follow the setting of the 
microjumper on the VDD pin header. 

5V Output of the 5.0V regulator. This is 
independent of the microjumper on the VDD 
pin header. 

3V Output of the 3.3V regulator. This is 
independent of the micro jumper on the VDD 
pin header. 

RST Reset Pin.  

U Unified Program and Debug Interface (UPDI) 

R Reserved. Do not use. 

0 to 21 GPIO pins - all of which are digital-only I/Os 
except for pins 13 – 21 which may be used as 
analog or digital I/O’s.  
Note: There is no pin 12 due to hardware 
limitations. 

 
See the “Hardware Peripherals” section for a detailed description of 
of the GPIO pins. 
 
 
 
 

OPERATING VOLTAGE ORIENTATION 
 
The user may change the operating voltage of the Saleng 128DB 
board by adjusting the orientation of microjumper at the VDD 
header located at the center of the board. This will affect all V pins 
and GPIO’s except the 4 MVIO pins whose operating voltage will 
depend on the microjumper orientation at the VDDIO2 pins header. 
These four pins are as follows: 
 

MODE PINS 

VDDIO2 8, 9, 10, 12 

 
Note: The two jumper wires must always be installed. 

 
There are 4 possible arrangements that can be used: 
 
1. VDD and VDDIO2 both uses 5 volts. 

 
2. VDD and VDDIO2 both uses 3.3 volts. 

 
3. VDD uses 5 volts while VDDIO2 uses 3.3 volts. 

 
4. VDD uses 3.3 volts while VDDIO2 uses 5 volts. 

 
 
POWER REQUIREMENTS AND OPTIONS 
 
The board may be powered from the following options. 
 

• MicroUSB port – the board is powered when plugged into 
the USB port of a computer or any power supply. Please 
ensure you are using a 5V power supply / charger / power 
bank. The port is designed for a maximum of 500mA only. 
A resettable fuse is installed in this port. 
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USB DRIVER INSTALLATION 
 
Saleng 128DB requires installation of the CH340 driver which is 
widely available for download online. This is required by the 
computer to recognize the board as a COM port (in Windows). 
Below is a step-by-step guide to install the driver: 
 
1. Download the latest version of the driver from the following: 

 Windows: 
https://layadcircuits.com/ds/SalengUno/drivers/CH341SER.ZIP  

 Mac: 
https://layadcircuits.com/ds/SalengUno/drivers/CH341SER_MAC.ZIP 

      Linux: built-in 
 
2. Extract the downloaded file with any zip extractor software 

 
 

3. Run the installer. 

 
4. On the window that pops up, click on the Install Button. 
5. Wait until installation is complete. Note that if you 

previously installed the driver, the installation may report a 
“failed” installation. If there is a need to reinstall, please 
uninstall first then reinstall.  

6. Reboot the computer. 
7. After reboot, insert the Saleng 128DB into one of the 

USB ports of the computer. The computer should now 
recognize the board. In Windows, the board will appear as a 
COM port under Ports in the Device Manager window. 

  
ADDING THE SALENG 128DBS BOARD IN THE ARDUINO IDE 
 
The Saleng 128DB requires installation of the core files to allow 
usage with the Arduino IDE. If interested, the core files are 
maintained in this repository: 
https://github.com/SpenceKonde/DxCore. 
 
 Below is a step-by-step instruction on how to install the board:  
Step 1: Copy the Link below or that from the repository: 

http://drazzy.com/package_drazzy.com_index.json 

 

Step 2: After copying the link, Open Arduino IDE. Go to File > 

Preferences. 

 

Step 3: Paste the link inside the Box beside “Additional Boards 

Manager URLs:” then Click “OK”. Separate with commas if there are 

other board links. 

 

Step 4: Go to Tools > Board > Boards Manager 

 

Step 5: Wait for the Platforms index to finish downloading.  

Step 6: Look for DxCore (You can search it on “filter your search”, 

just type ‘DxCore’) then click “Install”. Wait until the core is 

successfully installed. 

 

 
FIRST UPLOAD / TEST UPLOAD 
 
To confirm successful installation of the core and to test the board, 

follow the steps below to upload the “blink” sketch.  

https://layadcircuits.com/ds/SalengUno/drivers/CH341SER.ZIP
https://layadcircuits.com/ds/SalengUno/drivers/CH341SER_MAC.ZIP
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Step 1: Go to Tools > Board > DxCore and choose “AVR DB – series 

(optiboot)”  

 

Step 2: Follow the board settings below. The options and 

arrangement of these settings may vary in the future but as a 

general rule, set the Bootloader Serial Port to “USART0” and the 

printf() to “Full…” and keep the rest in default position.  

 
 
Step 3: Check your Port, make sure that your board is connected. Go 
to tools > Port > Serial Port and select the port number associated to 
your board. Note that the port number is assigned by your 
computer’s OS and may change between USB ports. 

 
Note: Install CH340 driver if the port associated with the board does 

not appear on the dropdown list under Tools>Ports  
 

Step 4: After choosing your port, Go to File > Examples > 01. Basics > 
Blink. Wait for the new sketch to pop out. 

 
 
 
 

Step 3: Run the code and wait for the code to finish uploading.  

 
 
Step 4: Check your Saleng 128DB if its blinking based on the code. 
 

Congratulations! You have successfully programmed your Saleng 
128DB. 

 
PERIPHERALS 
 
The following section discusses the different peripherals available in 
the Saleng 128DB with emphasis on the hardware/software features 
not available in the “classic” boards such as the Arduino 
Uno/Nano/Mega. 
 
GENERAL PURPOSE I/Os (GPIOs) 
 
There is a total of 21 GPIOs on the board following the classic 
labelling style from “0” to “21”. There is no pin 12. Below is a 
summary of the important details. Rows in blue are digital I/Os 
capable pins while those in orange are digital and analog capable 
I/Os. See also the “Detailed Pinout” section. 
 

Board 
Label 

Typical Function/s Notes 

0 Digital I/O, TXD0. This is the 
transmit pin of the “Serial” 
port connected to the 
microUSB port and used for 
uploading sketches and for 
printing output into the Serial 
Monitor  

Serial / Serial0 / 
HardwareSerial 0 / 
USART0. It is 
recommended not to 
use HardwareSerial 0 
pins unless absolutely 
required. If used for 
other purposes, it is 
recommended to 
momentarily 
disconnect the 
circuit/components 
attached to it while 
uploading. 

1 Digital I/O, RXD0. This is the 
receive pin of the “Serial” 
(Serial0 / HardwareSerial 
0/USART0) connected to the 
microUSB port and used for 
uploading sketches and for 
printing output into the Serial 
Monitor 

2 Digital I/O, SDA, PWM capable I2C port 

3 Digital I/O, SCL, PWM capable 

4 Digital I/O, MOSI, PWM 
capable, alternate pin for 
TXD0 

SPI port 

5 Digital I/O, MISO, PWM 
capable, alternate pin for 
RXD0 

6 Digital I/O, PWM capable, SCK 

7 Digital I/O, PWM capable, SS. 
Hardwired to the “L” LED  

8 Digital I/O, TXD1, MVIO. This is 
the transmit pin of the 
“Serial1” port 

Serial1 / 
HardwareSerial 1 / 
USART1 port 
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9 Digital I/O, RXD1, MVIO. This 
is the receive pin of the 
“Serial1” port 

10 Digital I/O, alternate pin for 
SDA, MVIO 

 

11 Digital I/O, alternate pin for 
SCL, MVIO 

 

13 Analog input, PWM capable, 
Digital I/O 

 

14 Analog input, PWM capable, 
Digital I/O 

 

15 Analog input, PWM capable, 
Digital I/O 

 

16 Analog input, PWM capable, 
Digital I/O 

 

17 Analog input, PWM capable, 
Digital I/O 

 

18 DAC output, Analog input, 
Digital I/O 

DAC pin 

19 Analog input, Digital I/O  

20 TXD2, Analog input, Digital 
I/O. This is the transmit pin of 
the “Serial2” port 

Serial2 / 
HardwareSerial 2 / 
USART2 port 

21 RXD2, Analog input, Digital 
I/O. This is the receive pin of 
the “Serial2” port 

 
ADC  
 
Saleng 128DB has a default resolution of 10-bits (0-1023) for 

compatibility with other boards but the maximum is 12-bits (0-

4095). To change the size into 12-bits, call the following function: 

analogReadResolution( ); 

An example code can be seen here: 

   

PWM 
 
Refer to the GPIO table for PWM capable pins. The pins 4 & 6, and 
pins 5 & 7 are linked, thus, each pair can only output one duty cycle 
at a time on one pin or on both pins. Both pairs cannot be used with 
the same duty cycle. 
 
Pin 8 is used as the default millis() timer, as a result it loses its 
capabilities to output PWM. 
 
ALTERNATE PINS FOR SERIAL INTERFACES 
 
Saleng 128DB have an alternate pin-mapping alternatives that can 
be swap with the default pins using the swap() command before  
initializing any of the interface( begin() ). 
 
I2C Alternate Interface 

 SDA SCL 

Default 2 3 

Alternate 10 11 

 

An example code can be seen here: 

 

 
 
 
 
 
 
 
 
 
 
 
 

 

void setup()  

{ 

  Serial.begin(9600);  

  //display pin 21's input at default -     

  //resolution (10 bit) 

  analogReadResolution (10 ); 

  Serial.print ("ADC in 10bits - "); 

  Serial.println (analogRead(21) ); 

 

  // change the resolution to 12bits 

  analogReadResolution (12); 

  Serial.print ("ADC in 12bits - "); 

  Serial.println (analogRead(21) ); 

 

  delay(1000); 

 

} 

void loop()  

{ 

} 

 

/*For this code, we connected an LCD with 

an I2C module to the saleng 128DB. Connect 

sda to pin 10 and scl to pin 11*/ 

 

#include <Wire.h>  

#include <LiquidCrystal_I2C.h> 

LiquidCrystal_I2C lcd(0x27,20,4); 

 

void setup() 

{ 

  Wire.swap(2); // swap default i2c pins 

to 10 and 11  

  lcd.init(); 

  lcd.backlight();// initialize the lcd  

  lcd.setCursor(1,0); 

  lcd.print("Testing..."); 

  lcd.setCursor(1,0); 

  lcd.print("Swap command"); 

} 

 

void loop(){ 

} 
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UART Alternate Interface 

 TX RX 

Default 0 1 

Alternate 4 5 

 
An example code can be seen here: 
 

 
 
SPI 
 
 There are two default SPI pins included in the Saleng 128DB board, 
their pins are: 

 SPI0 SPI1 

MOSI 4 8 

MISO 5 9 

SCK 6 10 

SS 7 11 

Level_name SPI0_SWAP_DEFAULT SPI1_SWAP_DEFAULT 

 
SPI0 is set as the default pins, but you can interchange them by using 
the code SPI.swap(level_name) before SPI.begin(). 
 
For more information concerning SPI, please refer to this website. 
 
On-Chip Opamps (OPAMP) 
 
Saleng 128DB have 2 on-chip Opamps. 

OPAMP + Pin - Pin OUT 

Opamp0 13 15 14 

Opamp1 16 19 17 

 
An example code can be seen here: 
 

 
 
For more information concerning OPAMP, please refer to this 
website. 
 
Servo Support 
 
The core  discussed in this document provides a version of the Servo 
library tailored for the Saleng 128DB. You can assess this by going to 
Sketch> Include Libraries> Servo_DxCore.h. Please Use this instead 
of Servo.h 
 
USEROW 
For more information concerning USEROW, please refer to this 
website. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

 

/*In this code, you must connect pins 4 and 

5 to a uart dongle and upload code. If code 

is successfull, the text "Serial Changed" 

will appear in the port your uart dongle. 

*/ 

void setup() 

{ 

  Serial.swap(1);//swaps pin 0&1 to 4&5 

  Serial.begin(9600); 

  Serial.print("Serial Changed"); 

} 

void loop() { 

} 

 

/* Opamp.h library is for interfacing with the 

built-in AVR-DB Opamp developed in 2021 by 

MCUdude   

 

In this code, we used opamp0 as a voltage 

follower. Meaning that the output is equal to 

the input voltage. 

*/ 

#include <Opamp.h> 

 

void setup()  

{ 

//Connect pin 13 to external input 

  Opamp0.input_p = in_p::pin;  

//Connect N-input to output internally     

  Opamp0.input_n = in_n::output;  

  Opamp0.output = out::enable;   //pin 14 

  Opamp0.init();  // Initialize Opamp0 

  Opamp::start(); // Start the Opamp hardware 

} 

 

void loop() { 

} 

https://github.com/SpenceKonde/DxCore/blob/master/megaavr/libraries/SPI/README.md
https://github.com/SpenceKonde/DxCore/tree/master/megaavr/libraries/Opamp
https://github.com/SpenceKonde/DxCore/tree/master/megaavr/libraries/USERSIG
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DETAILED PINOUTS 
 

 
 
 
COMPARISSON WITH ARDUINO, UNO, AND MEGA 
 

SPECIFICATION SALENG 128DB UNO MEGA 

Microcontroller AVR128DB28 ATmega328P ATmega2560 

Clock Frequency 24MHz 16MHz 16MHz 

SRAM Size 16KB 2KB 8KB 

Flash Size 128KB 32KB 256KB 

EEPROM Size 512B 1KB 4KB 

User Row Memory 32 None None  

Price Range Mid Mid High 

MCU Architecture / Release Year   Modern AVR / 2020s Classic AVR / 1990s Classic AVR / 1990s 

Number of I/O Pins 21 20 54 

Board Size  25mmx50mm 53mmx69mm 53mmx101.5mm 

PWM capable pins 11 6 15 

Max simultaneous PWM outputs 9 6 15 

Number of Analog Pins 9 x 12bits 6 x 10bits 16 x 10bits 
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ADC Resolution 12 bits 10 bits 10 bits 

External Interrupt Pins 19 2 6 

Language/IDE C/C++ / Arduino IDE C/C++ / Arduino IDE C/C++ / Arduino IDE 

DC Input Voltage Range via DC jack or 
Vin header 

7-12V Recommended 7-12V Recommended 7-12V Recommended 

Direct Breadboard Compatibility 
(bottom male headers) 

Yes 
Uno = No /  Nano = 
Yes 

No 

5V regulator current rating 1A 1A 1A 

3.3V regulator current rating 800mA 50mA 50mA 

Microcontroller operating voltage 5V or 3.3V  5V only 5V only 

Multi-Voltage I/O (5V/3.3V 
selectable) 

4  None None 

500mA PTC fuse on USB power Available Available Available 

Timers 4x 16-bit + 1x 12bit 1x 16 bit + 2x 8bit 4x 16bit + 2x 8bit 

Hardware Serial (UART) 3  1 4 

Alternate UART Pins Available None None 

SPI port 2 channels 1 channel 1 channel 

I2C port 1 channel 1 channel 1 channel 

Alternate I2C pins Available None None 

10-bit DAC 1 None None 

Analog Comparator 3 1 1 

Zero-Cross Detectors  2 None None 

On-chip Op amp 2 None None 

Custom Logic Blocks  4 None None 

Event System channels 8 channels None None 
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IMPORTANT NOTICE 

Layad Circuits Electronics Engineering Supplies & Services (Layad Circuits) reserves the right to make corrections, enhancements, improvements and other changes to 

its products, services and documentations, and to discontinue any product or service. Buyers or clients should obtain the latest relevant information before placing 

orders and should verify that such information is current and complete. Additional terms may apply to the use or sale of Layad Circuits products and services.  

Reproduction of significant portions of Layad Circuits information in Layad Circuits datasheets or user guides is permissible only if reproduction is without alteration, 

displays the Layad Circuits logo and is accompanied by all associated warranties, conditions, limitations, and notices. Layad Circuits is not responsible or liable for such 

reproduced documentation. Information of third parties may be subject to additional restrictions. Resale of Layad Circuits products or services with statements 

different from or beyond the parameters stated by Layad Circuits for that product or service voids all express and any implied warranties for the associated Layad 

Circuits product or service. Layad Circuits is not responsible or liable for any such statements.  

Buyers and others who are developing systems that incorporate Layad Circuits products (collectively, “Designers”) understand and agree that Designers remain 

responsible for using their independent analysis, evaluation and judgment in designing their applications and that Designers have full and exclusive responsibility to 

assure the safety of Designers' applications and compliance of their applications (and of all Layad Circuits products used in or for Designers’ applications) with all 

applicable regulations, laws and other applicable requirements. Designer represents that, with respect to their applications, Designer has all the necessary expertise 

to create and implement safeguards that (1) anticipate dangerous consequences of failures, (2) monitor failures and their consequences, and (3) lessen the likelihood 

of failures that might cause harm and take appropriate actions. Designer agrees that prior to using or distributing any applications that include Layad Circuits 

products, Designer will thoroughly test such applications and the functionality of such Layad Circuits products as used in such applications. Layad Circuits’ provision of 

technical, application or other design advice, quality characterization, reliability data or other services or information, including, but not limited to, reference designs 

and materials relating to evaluation modules, (collectively, “Layad Circuits Resources”) are intended to assist designers who are developing applications that 

incorporate Layad Circuits products; by downloading, accessing or using Layad Circuits Resources in any way, Designer (individually or, if Designer is acting on behalf 

of a company, Designer’s company) agrees to use any particular Layad Circuits Resource solely for this purpose and subject to the terms of this Notice.  

Layad Circuits' provision of Layad Circuits Resources does not expand or otherwise alter Layad Circuits’ applicable published warranties or warranty disclaimers for 

Layad Circuits products, and no additional obligations or liabilities arise from Layad Circuits providing such Layad Circuits Resources.  

Layad Circuits reserves the right to make corrections, enhancements, improvements and other changes to its Layad Circuits Resources. Layad Circuits has not 
conducted any testing other than that specifically described in the published documentation for a particular Layad Circuits Resource.  

NO OTHER LICENSE, EXPRESS OR IMPLIED, BY ESTOPPEL OR OTHERWISE TO ANY OTHER LAYAD CIRCUITS INTELLECTUAL PROPERTY RIGHT, AND NO LICENSE TO ANY 

TECHNOLOGY OR INTELLECTUAL PROPERTY RIGHT OF LAYAD CIRCUITS OR ANY THIRD PARTY IS GRANTED HEREIN, including but not limited to any patent right, 

copyright, mask work right, or other intellectual property right relating to any combination, machine, or process in which Layad Circuits products or services are used. 

Information regarding or referencing third-party products or services does not constitute a license to use such products or services, or a warranty or endorsement 

thereof. Use of Layad Circuits Resources may require a license from a third party under the patents or other intellectual property of the third party, or a license from 

Layad Circuits under the patents or other intellectual property of Layad Circuits. Layad Circuits RESOURCES ARE PROVIDED “AS IS” AND WITH ALL FAULTS. LAYAD 

CIRCUITS DISCLAIMS ALL OTHER WARRANTIES OR REPRESENTATIONS, EXPRESS OR IMPLIED, REGARDING RESOURCES OR USE THEREOF, INCLUDING BUT NOT LIMITED 

TO ACCURACY OR COMPLETENESS, TITLE, ANY EPIDEMIC FAILURE WARRANTY AND ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR 

PURPOSE, AND NON-INFRINGEMENT OF ANY THIRD PARTY INTELLECTUAL PROPERTY RIGHTS. LAYAD CIRCUITS SHALL NOT BE LIABLE FOR AND SHALL NOT DEFEND OR 

INDEMNIFY DESIGNER AGAINST ANY CLAIM, INCLUDING BUT NOT LIMITED TO ANY INFRINGEMENT CLAIM THAT RELATES TO OR IS BASED ON ANY COMBINATION OF 

PRODUCTS EVEN IF DESCRIBED IN LAYAD CIRCUITS RESOURCES OR OTHERWISE. IN NO EVENT SHALL LAYAD CIRCUITS BE LIABLE FOR ANY ACTUAL, DIRECT, SPECIAL, 

COLLATERAL, INDIRECT, PUNITIVE, INCIDENTAL, CONSEQUENTIAL OR EXEMPLARY DAMAGES IN CONNECTION WITH OR ARISING OUT OF LAYAD CIRCUITS RESOURCES 

OR USE THEREOF, AND REGARDLESS OF WHETHER LAYAD CIRCUITS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Unless Layad Circuits has explicitly 

designated an individual product as meeting the requirements of a particular industry standard, Layad Circuits is not responsible for any failure to meet such industry 

standard requirements. Where Layad Circuits specifically promotes products as facilitating functional safety or as compliant with industry functional safety standards, 

such products are intended to help enable customers to design and create their own applications that meet applicable functional safety standards and requirements. 

Using products in an application does not by itself establish any safety features in the application. Designers must ensure compliance with safety-related 

requirements and standards applicable to their applications. Designer may NOT use any Layad Circuits products in life-critical applications. Life-critical medical 

equipment is medical equipment where failure of such equipment would cause serious bodily injury or death (e.g., life support, pacemakers, defibrillators, heart 

pumps, neurostimulators, and implantable). Designers agree that it has the necessary expertise to select the product with the appropriate qualification designation 

for their applications and that proper product selection is at Designers’ own risk. Designers are solely responsible for compliance with all legal and regulatory 

requirements in connection with such selection. Designer will fully indemnify Layad Circuits and its representatives against any damages, costs, losses, and/or 
liabilities arising out of Designer’s noncompliance with the terms and provisions of this Notice. 

 



 
 

www.layadcircuits.com                                                                                                           Copyright 2022 © Layad Circuits All Rights Reserved 
Layad Circuits Electronics Engineering Supplies & Services, B314 Lopez Bldg., Session Rd. cor. Assumption Rd., Baguio City, Philippines 
General inquiries: info@layadcircuits.com       Sales: sales@layadcircuits.com           FB: facebook.com/layadcircuits                Mobile: +639164428565 

An IMPORTANT NOTICE: at the end of this guide addresses availability, warranty, changes, use in safety-critical applications, intellectual property matters and other important disclaimers. 
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